$re = '/src\="https:\/\/exemplo\.files\.wordpress\.com(.*?)"/';
$str = '<img src="https://exemplo.files.wordpress.com/2018/04/30656289_1739197086123960_7879125475971301376_o.jpg">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);