# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Za-z0-9]+)\.HasNext/!\1.IsEnd/gm;t' <<< "for (local tile = tileList.Begin(); tileList.HasNext(); tile = tileList.Next()) {"