$re = '/([A-Za-z0-9]+)\.HasNext/m';
$str = 'for (local tile = tileList.Begin(); tileList.HasNext(); tile = tileList.Next()) {';
$subst = "!\1.IsEnd";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;