\d{4}a digit, repeated exactly 4 times
\sany whitespace character
\Sany non-whitespace character
.+any character (except for line terminators), repeated at least once
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string