#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)\b(?!(.)\1)(?:[rs]{1,2}|[as]{1,2})\b"
Local $sString = "r" & @CRLF & _
"s" & @CRLF & _
"a" & @CRLF & _
"rs" & @CRLF & _
"sr" & @CRLF & _
"as" & @CRLF & _
"sa" & @CRLF & _
"ss" & @CRLF & _
"rr" & @CRLF & _
"aa" & @CRLF & _
"ra - ar" & @CRLF & _
"asr - ars - sra - sar - rsa - ras "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")