$re = '/\b(?!(.)\1)(?:[rs]{1,2}|[as]{1,2})\b/u';
$str = 'r
s
a
rs
sr
as
sa
ss
rr
aa
ra - ar
asr - ars - sra - sar - rsa - ras ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);