const regex = /(?:'(\w+)|\G(?<!^))(?:;(\w+)=(\w+))?(?::([^']*)'.*$)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\'(\\w+)|\\G(?<!^))(?:;(\\w+)=(\\w+))?(?::([^\']*)\'.*$)?', 'gm')
const str = `\$subject = 'name:content' ;
\$subject = 'name;param1=value1:content' ;
\$subject = 'name;param11=value11;param21=value21:content' ;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}