re = /[^,\s]*\b"\b[^,\s]*|"[^"]*"|[^,\s]+/m
str = '"Super Bus" dri"ver bus1, dri"ver1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end