using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(h[2-4])>((?:(?!<h\d+\b).)+?)<\/\1>";
string substitution = @"";
string input = @"<h2>goo</h2> <h4>goo</h2> <h4>goo</h4> <h4>goo'<>bar</h4>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}