$re = '/(?=(([^"]*"){2})*[^"]*$),/';
$str = 'foo bar,"3,14","1,000,000",hippo,"cat,dog,frog",plain text,"2,25"';
$subst = ";";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;