$re = '/<(?<tag>\w+)(?:\s+(?<attrs>.*?))?>(?<content>.*)<\/\1>/';
$str = '<p id="12">Hello </h> </p>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);