using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{%((?:[^%]|%[^\}])+)%\}";
string input = @"{%
function check(a, b) {
if ($object[a] && (b === undefined || $object[b])) {
$write(""checked"");
}
}
%}
<tr>
<td>{{name}}</td>
<td>{{description}}</td>
<td><input type=""checkbox"" {%%}=""check('load');""></td>
<td><input type=""checkbox"" {%%}=""check('load', 'test');""></td>
<td><input type=""checkbox"" {%%}=""check('doc');""></td>
</tr>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}