using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<CHAR>(.*?)<\/CHAR>";
string input = @" <MSG><KEY>name.extObject</KEY><PARAM><CHAR>Number</CHAR><CHAR>7015:188188</CHAR></PARAM></MSG>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}