re = /<CHAR>(.*?)<\/CHAR>/
str = ' <MSG><KEY>name.extObject</KEY><PARAM><CHAR>Number</CHAR><CHAR>7015:188188</CHAR></PARAM></MSG>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end