$re = '/^.*(\d)([A-Za-z0-9-\-\/]+)?/m';
$str = '1/24-26 \'Wuthering Heights\' Onslow Ave Elizabeth Bay
1/24-26b \'Wuthering Heights\' Onslow Ave Elizabeth Bay
\'Wuthering Heights\' 1/24-26b Onslow Ave Elizabeth Bay
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);