$re = '/(?<=\d)[A-Za-z]+(?=_)/i';
$str = 'CP_01Ags_v5
CP_13Hgo_v5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);