#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d*(\d)\1{3}\d*$"
Local $sString = "Thnx Chappell for your feedback, i have to block phone number like :" & @CRLF & _
"0600000450" & @CRLF & _
"0511111320" & @CRLF & _
"0425888888" & @CRLF & _
"123" & @CRLF & _
"123456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")