using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d*(\d)\1{3}\d*$";
string input = @"Thnx Chappell for your feedback, i have to block phone number like :
0600000450
0511111320
0425888888
123
123456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}