package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?::?%[nmp])+$`)
var str = `%n%m%p
%n:%m%p
%n3%p%m
%nm`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}