#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)((?<!:)[^\p{L}\p{N}])\1+"
Local $sString = "Hello... how are you!!?? I''m bored!!----!!!&&&&&^^^^%%%(()))((<<<<<" & @CRLF & _
"My ////favorite//// site is http://///example.com!!!!!!!"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)