# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\w+)\R(?=.*?^\1$)//gmis;t' <<< "Apple
Banana
TEST
apple
Cherry
banana
bananA
Var
cherry
applE
cherrY"