#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mis)^(\w+)\R(?=.*?^\1$)"
Local $sString = "Apple" & @CRLF & _
"Banana" & @CRLF & _
"TEST" & @CRLF & _
"apple" & @CRLF & _
"Cherry" & @CRLF & _
"banana" & @CRLF & _
"bananA" & @CRLF & _
"Var" & @CRLF & _
"cherry" & @CRLF & _
"applE" & @CRLF & _
"cherrY"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)