using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w+)\R(?=.*?^\1$)";
string substitution = @"";
string input = @"Apple
Banana
TEST
apple
Cherry
banana
bananA
Var
cherry
applE
cherrY";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}