use strict;
my $str = 'Apple
Banana
TEST
apple
Cherry
banana
bananA
Var
cherry
applE
cherrY';
my $regex = qr/^(\w+)\R(?=.*?^\1$)/misp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";