re = /^(\w+)\R(?=.*?^\1$)/mi
str = 'Apple
Banana
TEST
apple
Cherry
banana
bananA
Var
cherry
applE
cherrY'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result