# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)^((?:[^,\r\n]*,){X})[^,\r\n]*,((?:[^,\r\n]*,){Y})[^,\r\n]*(.*)"
test_str = ("a,{X}b,c,{Y}d\n"
"aaa,{X}2.15,100.15,{Y}-\n"
"bbb,{X}3.16,215.16,{Y}-\n"
"ccc,{X}4.10,365.18,{Y}-")
subst = "$1$2$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.