Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^(?<day>0[1-9]|1\d|2[1-8]|29(?=-\d{2}-(?!1[26]00|2[048]00)\d{2}(?:[02468][048]|[13579][26]))|30(?!-02)|31(?=-0[13578]|-1[02]))-(?<month>0[1-9]|1[0-2])-(?<year>[12]\d{3}) (?<hour>[01]\d|2[0-3]):(?<minute>[0-5]\d):(?<second>[0-5]\d)$
/
gm
Input 1
1
New
29-02-1600 15:11:45 29-02-1604 23:59:59 29-02-2001 15:11:45 31-01-2000 00:00:00 30-02-2000 15:11:45 29-02-2004 15:11:45 31-02-2000 15:11:45 31-12-2000 15:11:45 31-06-2000 15:11:45 15-02-2000 15:11:45 29-02-2002 15:11:45 02-02-2000 15:11:45 29-02-2000 15:11:45 28-02-2000 15:11:45