import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$\\{([\\w.]+)*(?::([\\w]+))?\\}";
final String string = "this is a ${partId} in a sentence\n"
+ "this is a ${param.someId} in a sentence\n"
+ "this is a ${partId:number} in a sentence\n"
+ "this is a ${userId:string} in a sentence\n"
+ "this is a ${param.someFlag:boolean} in a sentence\n"
+ "a ${lotId} and a ${panelId} in a sentence";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}