#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^a-zA-Z0-9\p{Cyrillic} ]"
Local $sString = "қасымалы дияр abcdef" & @CRLF & _
"test NbТитаренко"
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)