using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^a-zA-Z0-9\p{Cyrillic} ]";
string substitution = @"-";
string input = @"қасымалы дияр abcdef
test NbТитаренко";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}