re = /"[^"\\]*(?:\\.[^"\\]*)*"|\S+/
str = 'This is "a string" and this is "a \\"nested\\" string"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end