use strict;
my $str = '"y": [15, 15, 15, 15, 15, 15, 15, 15, 15, 15, 15]';
my $regex = qr/"y".*\[\s?(\d*)\s?,/p;
my $subst = '\\0\\1,\\1,\\1,\\1,\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";