using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"replace[d]?([A-Z a-z 0-9]+)with([A-Z a-z 0-9]+)";
string input = @"replaceorangeswithapples
replacebluewithred
replacecarswithbuses";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}