package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)replace[d]?([A-Z a-z 0-9]+)with([A-Z a-z 0-9]+)`)
var str = `replaceorangeswithapples
replacebluewithred
replacecarswithbuses`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}