Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([+-]?(?:'.+?'|".+?"|[^+\- ]{1}[^ ]*))
/
g
Test String
New
something else +good -bad 'other stuff' ++'good stuff' -"bad stuff" ---"dall'orto" a v ac