# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'[^']*'(*SKIP)(*F)|"/'/g;t' <<< "\"foo\"
=> 'foo'
'foo'
=> 'foo'
abc \"foo\"
=> abc 'foo'
foo \"bar\", \"baz\"
=> foo 'bar', 'baz'
abc 'foo \"bar\" baz'
=> abc 'foo \"bar\" baz'"