#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "'[^']*'(*SKIP)(*F)|""
Local $sString = ""foo"" & @CRLF & _
" => 'foo'" & @CRLF & _
"'foo'" & @CRLF & _
" => 'foo'" & @CRLF & _
"abc "foo"" & @CRLF & _
" => abc 'foo'" & @CRLF & _
"foo "bar", "baz"" & @CRLF & _
" => foo 'bar', 'baz'" & @CRLF & _
"abc 'foo "bar" baz'" & @CRLF & _
" => abc 'foo "bar" baz'"
Local $sSubst = "'"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)