use strict;
my $str = '"foo"
=> \'foo\'
\'foo\'
=> \'foo\'
abc "foo"
=> abc \'foo\'
foo "bar", "baz"
=> foo \'bar\', \'baz\'
abc \'foo "bar" baz\'
=> abc \'foo "bar" baz\'';
my $regex = qr/'[^']*'(*SKIP)(*F)|"/p;
my $subst = '\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";