re = /'[^']*'(*SKIP)(*F)|"/
str = '"foo"
=> \'foo\'
\'foo\'
=> \'foo\'
abc "foo"
=> abc \'foo\'
foo "bar", "baz"
=> foo \'bar\', \'baz\'
abc \'foo "bar" baz\'
=> abc \'foo "bar" baz\''
subst = '\''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result