import Foundation
let pattern = #"'[^']*'(*SKIP)(*F)|""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"foo"
=> 'foo'
'foo'
=> 'foo'
abc "foo"
=> abc 'foo'
foo "bar", "baz"
=> foo 'bar', 'baz'
abc 'foo "bar" baz'
=> abc 'foo "bar" baz'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)