$re = '/\((\w+)\)|z(\w+),/';
$str = 'Hi. (sad) I\'ve got bad news. zsad,
Hey... (sad)
Okay. Bye. zsad,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);