using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"NAME(.*)(?:FROM|$)";
string input = @"NAME John Nash FROM California
NAME John Nash";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}