#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\((?:([^\(\)]*)|(?:(?2)(?1)(?2))*)\))"
Local $sString = "(asdfa(adas)(asdfad)adsafdfa ( ()()) asad (asdfasdf)asdfa)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")