re = /(\((?:([^\(\)]*)|(?:(?2)(?1)(?2))*)\))/
str = '(asdfa(adas)(asdfad)adsafdfa ( ()()) asad (asdfasdf)asdfa)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end