Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\((?:([^\(\)]*)|(?:(?2)(?1)(?2))*)\))
/
Input 1
1
New
(asdfa(adas)(asdfad)adsafdfa ( ()()) asad (asdfasdf)asdfa)