use strict;
my $str = 'http://www.gettyimages.com/license/182149877?share=site_twitter';
my $regex = qr/(?:https?:\/\/)?(?:www\.)?(?:gettyimages|gty)\.(?:\w+)\/(?:license|detail)\/(\d+).*/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}