$re = '/(?:https?:\/\/)?(?:www\.)?(?:gettyimages|gty)\.(?:\w+)\/(?:license|detail)\/(\d+).*/i';
$str = 'http://www.gettyimages.com/license/182149877?share=site_twitter';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);