#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\S*(?:[Ss]mall|[Ll]arge|[Mm]edium|Med[.])\S*)"
Local $sString = "some text Small some text" " & @CRLF & _
"2 "some text small-med some text"" & @CRLF & _
"3 "some text Med. some text" " & @CRLF & _
"4 "some text medium some text" " & @CRLF & _
"5 "some text med-large some text" " & @CRLF & _
"6 "some text large some text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")