use strict;
my $str = 'some text Small some text"
2 "some text small-med some text"
3 "some text Med. some text"
4 "some text medium some text"
5 "some text med-large some text"
6 "some text large some text';
my $regex = qr/(\S*(?:[Ss]mall|[Ll]arge|[Mm]edium|Med[.])\S*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}