// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\S*(?:[Ss]mall|[Ll]arge|[Mm]edium|Med[.])\S*)").unwrap();
let string = "some text Small some text\"
2 \"some text small-med some text\"
3 \"some text Med. some text\"
4 \"some text medium some text\"
5 \"some text med-large some text\"
6 \"some text large some text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}